summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 3 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8a45ff6f1ac8..941d29bb9fb0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -92,16 +92,13 @@ options=("!strip")
PKGEXT='.pkg.tar'
prepare() {
- if df "${srcdir}" | grep -q tmpfs; then
- warning "Building Mathematica takes more than 8GB of space."
- warning "Building in a tmpfs (e.g. /tmp when mounted into RAM) may not work."
- fi
+ warning "Building Mathematica takes more than 8GB of space."
+ warning "Building in a tmpfs (e.g. /tmp when mounted into RAM) may not work."
if [ $(echo "${srcdir}" | wc -w) -ne 1 ]; then
msg2 "ERROR: The Mathematica installer doesn't support directory names with spaces."
- msg2 "Try building from a directory without spaces."
msg2 "Current build directory: ${srcdir}"
- false
+ exit 1
fi
chmod +x ${srcdir}/Mathematica_${pkgver}_LINUX.sh