summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 6 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 155bbe5f8169..9f799fbfccda 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,24 @@
# Maintainer: Zhiwei Chen <condy0919@gmail.com>
pkgname=merlin
-pkgver=4.5
-_pkgver=$pkgver-414
+pkgver=4.8
+_pkgver=$pkgver-500 # Yes, it builds
pkgrel=1
pkgdesc="Context sensitive completion for OCaml in Vim and Emacs"
arch=('x86_64')
-depends=('ocaml' 'ocaml-findlib' 'ocaml-yojson<2.0.0')
+depends=('ocaml' 'ocaml-yojson' 'ocaml-csexp')
makedepends=('git' 'dune')
url="https://github.com/ocaml/merlin"
license=('MIT')
source=("${url}/releases/download/v${_pkgver}/${pkgname}-${_pkgver}.tbz")
-sha256sums=('31587b422b5ebd3eebda730e946868807d829128f8dc7153fb05c0c82742058e')
+sha256sums=('9f93472aea34fe56667deed6b24aa75b7c66d52d0f9972924bddc10caae98c22')
options=('!strip')
-provides=('merlin')
-conflicts=('merlin' 'vim-ocaml-merlin-git')
+conflicts=('vim-ocaml-merlin-git')
build() {
cd "${srcdir}/${pkgname}-${_pkgver}"
- dune build -p merlin
+ make all
}
package() {