summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 7 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4a6f8d891223..4718f4213e67 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,10 +5,11 @@
# Contributor: mickele
# Contributor: gborzi
# Contributor: abenson
+# Contributor: Jakub Klinkovský <j.l.k cat gmx dog com>
_base=METIS
pkgname=${_base,,}
pkgver=5.2.1
-pkgrel=1
+pkgrel=2
arch=(x86_64)
pkgdesc="Serial Graph Partitioning and Fill-reducing Matrix Ordering"
url="https://github.com/KarypisLab/${_base}"
@@ -19,18 +20,14 @@ options=(docs)
source=(${_base}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz)
sha512sums=('69127b7a777f9ba14cf399a7122000af9d6094a5f44be600a28384cfc0495c024fb0c6eab37c4473a5763ec1077cd9f30d9bcbb3c952462f6c9ead31c6b9e790')
+prepare() {
+ cd ${_base}-${pkgver}
+ echo "target_link_libraries(metis PUBLIC \"-lGKlib\")" >>"libmetis/CMakeLists.txt"
+}
+
build() {
cd ${_base}-${pkgver}
make config \
- i64=0 \
- r64=0 \
- gdb=0 \
- assert=0 \
- assert2=0 \
- debug=0 \
- gprof=0 \
- valgrind=0 \
- openmp=0 \
shared=1 \
cc=gcc \
prefix=/usr \