summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 21 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 99cd4b6c81d7..835813e42abe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,41 @@
-# Maintainer: Grey Christoforo <first name at last name dot net>
+# Maintainer:
+# Contributor: Grey Christoforo <first name at last name dot net>
# Contributer: mickael9 <mickael9 at gmail dot com>
_number_of_bits=8
pkgname=microchip-mplabxc${_number_of_bits}-bin
-pkgver=2.36
+pkgver=2.45
pkgrel=1
pkgdesc="Microchip's MPLAB XC${_number_of_bits} C compiler toolchain for their PIC10/12/16/18 microcontroller families and their PIC14000 device"
arch=(x86_64)
-url=http://www.microchip.com/mplab/compilers
+url="https://www.microchip.com/mplab/compilers"
license=(custom)
+
depends=(gcc-libs)
makedepends=(bitrock-unpacker tclkit)
+
conflicts=(lib32-tclkit)
+install=$pkgname.install
+
options=(!strip docs libtool emptydirs !zipman staticlibs )
-source=("http://ww1.microchip.com/downloads/en/DeviceDoc/xc${_number_of_bits}-v${pkgver}-full-install-linux-x64-installer.run")
-md5sums=('e7be40f083398ec9d1abe2eefd26b88a')
-install=$pkgname.install
+_dl_url="https://ww1.microchip.com"
+_dl_path="downloads/aemDocuments/documents/DEV/ProductDocuments/SoftwareTools"
+_dl_file="xc${_number_of_bits}-v${pkgver}-full-install-linux-x64-installer.run"
-_instdir="opt/microchip/xc${_number_of_bits}/v${pkgver}"
+source=(
+ "$_dl_file"::"$_dl_url/$_dl_path/$_dl_file"
+)
+sha256sums=(
+ '3a48acd8150be7807ef10738fb9f915bc30963b385ce25fb84d151df49e13656'
+)
-PKGEXT='.pkg.tar'
+_instdir="opt/microchip/xc${_number_of_bits}/v${pkgver}"
build() {
- msg2 "Unpacking files from installer"
- bitrock-unpacker ./xc${_number_of_bits}-v${pkgver}-full-install-linux-x64-installer.run ./unpacked.vfs
+ echo "Unpacking files from installer"
+ bitrock-unpacker "./$_dl_file" ./unpacked.vfs
}
package() {
@@ -44,7 +54,7 @@ package() {
mkdir -p "${pkgdir}/usr/share/licenses/${pkgname}"
ln -s "/${_instdir}/docs/$(basename "${pkgdir}/${_instdir}/docs"/*[Ll]icense.txt)" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
-
+
chmod u+s "${pkgdir}/${_instdir}/bin/xclm"
chmod +x "${pkgdir}/${_instdir}/pic/bin/clang"
}