summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 13 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e084e6911e20..282960ed6f68 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,26 @@
pkgname=mingw-w64-shaderc
-pkgver=2020.0
+pkgver=2021.2
pkgrel=1
pkgdesc='Collection of tools, libraries and tests for shader compilation (mingw-w64)'
url='https://github.com/google/shaderc'
arch=('any')
license=('Apache')
depends=('mingw-w64-glslang')
-makedepends=('mingw-w64-cmake' 'mingw-w64-spirv-headers' 'python')
+makedepends=('mingw-w64-cmake' 'mingw-w64-spirv-headers' 'mingw-w64-spirv-tools' 'python')
options=('!strip' '!buildflags' 'staticlibs')
-source=(https://github.com/google/shaderc/archive/v${pkgver}.tar.gz)
-sha256sums=('e02e2a9d4c3960bc629ca8cdcf83d295bec9c80ed08a8c5062e4e294022605ec')
+source=(https://github.com/google/shaderc/archive/v${pkgver}.tar.gz
+ "0001-fix-glslang-hlsl-linking-order.patch")
+sha256sums=('d0d75beced49c7a03ae30bb4a879a3c7f2218ad66af19a115f665d07f37167ba'
+ '7d9c2605a4dab0e718c7fd3c7bfa2ea80968d8caa1937d8f0eaee3dc7c2f4e1d')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
prepare() {
cd shaderc-$pkgver
- curl -L https://github.com/google/shaderc/pull/463.patch | patch -p1
-
+
+ # https://www.mail-archive.com/devel@lists.fedoraproject.org/msg156020.html
+ patch -Nbp1 -i "${srcdir}/0001-fix-glslang-hlsl-linking-order.patch"
+
# de-vendor libs and disable git versioning
sed '/examples/d;/third_party/d' -i CMakeLists.txt
sed '/build-version/d' -i glslc/CMakeLists.txt
@@ -29,9 +33,12 @@ EOF
build() {
cd shaderc-$pkgver
+ local -a _glslang_inc
for _arch in ${_architectures}; do
mkdir -p build-${_arch} && pushd build-${_arch}
+ _glslang_inc="/usr/${_arch}/include/glslang"
${_arch}-cmake \
+ -Dglslang_SOURCE_DIR=${_glslang_inc} \
-DCMAKE_BUILD_TYPE=Release \
-DSHADERC_SKIP_TESTS=ON \
-DBUILD_SHARED_LIBS=OFF \