summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 16 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c4cbfbb8a95b..41bae2edcd11 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,44 +1,43 @@
# Maintainer: Patrick Northon <northon_patrick3@yahoo.ca>
pkgname=mingw-w64-xalan-c-git
-conflicts=("mingw-w64-xalan-c")
-provides=("mingw-w64-xalan-c")
-pkgver=r2.d8240ca
+conflicts=('mingw-w64-xalan-c')
+provides=('mingw-w64-xalan-c')
+pkgver=1.12.0.r10.g58dc1ac6c
pkgrel=1
-pkgdesc="A XSLT processor for transforming XML documents (mingw-w64)"
+pkgdesc='A XSLT processor for transforming XML documents (mingw-w64)'
arch=(any)
-url="https://xalan.apache.org/"
-license=("APACHE")
+url='https://xalan.apache.org/'
+license=('APACHE')
makedepends=('mingw-w64-cmake' 'mingw-w64-wine' 'git')
depends=('mingw-w64-crt' 'mingw-w64-xerces-c')
options=('!strip' '!buildflags' 'staticlibs')
source=("git+https://github.com/apache/xalan-c"
- "fix-cross-compile.patch")
+ 'fix-cross-compile.patch')
sha256sums=(
- "SKIP"
- "08400961f038c1aed090174425e894673ffc359b52bcbad73d2c537a89ea34b7")
+ 'SKIP'
+ 'bffe4d394b877d7a36c08efd7563ce9ccde3621ae3851dc9c00ce065cd360050')
-_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
pkgver() {
- cd "${_repo}"
+ cd "xalan-c"
( set -o pipefail
- git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ git describe --long 2>/dev/null | sed 's/^Xalan.C_//;s/_/./g;s/\([^-]*-g\)/r\1/;s/-/./g' ||
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
)
}
prepare() {
- cd "xalan-c"
- git apply "../fix-cross-compile.patch"
- sed -i -r "s/_MSC_VER/_WIN32/" "src/xalanc/XalanExe/XalanExe.cpp"
+ cd 'xalan-c'
+ patch -uNp1 < '../fix-cross-compile.patch'
}
build() {
- _flags=( -Wno-dev -DCMAKE_BUILD_TYPE=Release -DCMAKE_CXX_FLAGS_RELEASE="-O2 -DNDEBUG" -Ddoxygen=OFF )
+ _flags=( -Wno-dev -DCMAKE_BUILD_TYPE=Release -DCMAKE_CXX_FLAGS_RELEASE='-O2 -DNDEBUG' -Ddoxygen=OFF )
for _arch in ${_architectures}; do
- ${_arch}-cmake -S "xalan-c" -B "build-${_arch}" "${_flags[@]}"
+ ${_arch}-cmake -S 'xalan-c' -B "build-${_arch}" "${_flags[@]}"
cmake --build "build-${_arch}"
done
}