summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD62
1 files changed, 62 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..43e29042622a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,62 @@
+#Maintainer: Simon Eriksson <simon.eriksson.1187+aur AT gmail.com>
+
+_target=mips64-elf
+pkgname=${_target}-binutils
+pkgver=2.25.1
+pkgrel=1
+pkgdesc="A set of programs to assemble and manipulate binary and object files (${_target})"
+url="http://www.gnu.org/software/binutils/"
+arch=('i686' 'x86_64')
+license=('GPL')
+depends=('zlib')
+source=("ftp://ftp.gnu.org/gnu/binutils/binutils-${pkgver}.tar.bz2")
+sha256sums=('b5b14added7d78a8d1ca70b5cb75fef57ce2197264f4f5835326b0df22ac9f22')
+
+prepare() {
+ cd binutils-${pkgver}
+
+ # Hack - see native package for details
+ sed -i "/ac_cpp=/s/\$CPPFLAGS/\$CPPFLAGS -O2/" libiberty/configure
+}
+
+check() {
+ cd binutils-$pkgver
+
+ # unset LDFLAGS as testsuite makes assumptions about which ones are active
+ # do not abort on errors - manually check log files
+ make LDFLAGS="" -k check
+}
+
+build() {
+
+ cd binutils-${pkgver}
+
+ ./configure \
+ --target=${_target} \
+ --prefix=/usr \
+ --with-sysroot=/usr/${_target} \
+ --with-gnu-as \
+ --with-gnu-ld \
+ --enable-64-bit-bfd \
+ --enable-gold \
+ --enable-plugins \
+ --enable-static \
+ --disable-multilib \
+ --disable-nls \
+ --disable-shared \
+ --disable-werror \
+
+ make
+}
+
+package() {
+ cd binutils-${pkgver}
+
+ make DESTDIR="$pkgdir" install
+
+ # Remove file conflicting with host binutils and manpages for MS Windows tools
+ rm "$pkgdir"/usr/share/man/man1/$_target-{dlltool,nlmconv,windres,windmc}*
+
+ # Remove info documents that conflict with host version
+ rm -rf "$pkgdir"/usr/share/info
+}