summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..864407170ec9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Jakob Gruber (jakob dot gruber at kabelnet dot at)
+
+_pkgname="mkwvconf"
+pkgname="$_pkgname-git"
+pkgver=0.1
+pkgdesc="Automatically generate a wvdial configuration for mobile broadband devices."
+pkgrel=1
+arch=('any')
+url="http://github.com/schuay/mkwvconf"
+license=('GPL')
+depends=('mobile-broadband-provider-info' 'python2' 'pyxml')
+makedepends=('git')
+
+build() {
+ rm -rf "${srcdir}/*"
+
+ cd "${srcdir}"
+ git clone git://github.com/schuay/mkwvconf.git
+}
+
+package() {
+ cd "${srcdir}/$_pkgname"
+ install -Dm755 mkwvconf.py "${pkgdir}/usr/bin/mkwvconf"
+}
+