summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 9 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bef26a61ac24..b85abafc255a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,14 @@
pkgname=mlink
pkgver=1.2.0
-pkgrel=1
+pkgrel=2
pkgdesc='A tool connecting mBlock web version to devices'
arch=(x86_64)
url='https://www.mblock.cc/en-us/download'
-# main program licence is unknown, but bundled node_modules are various
-license=(custom)
-# use rpm not deb, because (a) makepkg auto-expands rpms and (b) permissions in rpm are already correct for mlink
-# source=("https://dl.makeblock.com/mblock5/linux/mLink-1.2.0-amd64.deb")
+license=(custom) # main program licence is unknown, but bundled node_modules are various
+install=$pkgname.install
+# source from rpm not deb, because (a) makepkg auto-expands rpms and (b) permissions in rpm are already correct for mlink
+# alternatively source=("https://dl.makeblock.com/mblock5/linux/mLink-1.2.0-amd64.deb")
source=("https://dl.makeblock.com/mblock5/linux/mLink-1.2.0-1.el7.x86_64.rpm")
sha256sums=('1625de43bd7639ce87c3d0b05bac82336df8860351b35f113f93d0140b830c3b')
@@ -19,5 +19,9 @@ prepare() {
}
package() {
+ # install mlink
cp -r usr "${pkgdir}"
+ # install systemd service
+ mkdir -p "${pkgdir}/usr/lib/systemd/system"
+ cp ../$pkgname.service "${pkgdir}/usr/lib/systemd/system"
}