summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD6
1 files changed, 5 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6408cd29413b..c45b9955c4a4 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -42,7 +42,11 @@ build() {
-DENABLE_PYMOAB=ON \
-DBUILD_SHARED_LIBS=ON \
-DCMAKE_INSTALL_PREFIX=/opt/MOAB
- make
+ _ccores=`cat /proc/cpuinfo |grep CPU|wc -l`
+ if [ "x$1" != "x" ]; then
+ _ccores=$1
+ fi
+ make -j ${_ccores}
}
package() {