summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 13 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7e66d01be1af..65f4912c5fce 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,29 @@
# Maintainer: Richard Neumann aka. schard <mail at richard dash neumann period de>
pkgname='mollyguardctl'
-pkgver=1.3.9
-pkgrel=2
+pkgver=1.3.10
+pkgrel=1
pkgdesc='Guards your system from accidental reboots and shutdowns'
arch=('any')
url="https://github.com/coNQP/${pkgname}"
license=('GPLv3')
depends=('python' 'python-setuptools')
-makedepends=('git' 'python-setuptools-scm')
+makedepends=('git' 'python-build' 'python-installer' 'python-setuptools-scm' 'python-wheel')
source=("git+${url}.git#tag=${pkgver}")
md5sums=('SKIP')
build() {
- cd "${pkgname}"
- python setup.py build
+ cd "${srcdir}/${pkgname}"
+ python -m build --wheel --no-isolation
}
package() {
- cd "${pkgname}"
- python setup.py install --root "${pkgdir}" --optimize=1 --skip-build
+ cd "${srcdir}/${pkgname}"
+ python -m installer --destdir="$pkgdir" dist/*.whl
+
+ install -dm 755 "${pkgdir}/usr/lib/systemd/system"
+
+ for UNIT in *.service; do
+ install -m 644 "${UNIT}" "${pkgdir}/usr/lib/systemd/system/"
+ done
}