summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 20 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 18ad30954a4e..11abfa10f9a6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,30 @@
# Maintainer: Mark Wagie <mark dot wagie at proton dot me>
pkgname=mousai
_app_id=io.github.seadve.Mousai
-pkgver=0.7.6
-pkgrel=2
+pkgver=0.7.7
+pkgrel=1
pkgdesc="Simple application for identifying songs"
arch=('x86_64')
url="https://apps.gnome.org/Mousai"
license=('GPL-3.0-or-later')
-depends=('gst-plugins-bad-libs' 'gst-plugins-good' 'gstreamer' 'libadwaita'
- 'libpulse' 'libsoup3')
-makedepends=('cargo' 'meson')
-checkdepends=('appstream-glib')
+depends=(
+ 'gst-plugins-bad-libs'
+ 'gst-plugins-good'
+ 'gstreamer'
+ 'libadwaita'
+ 'libpulse'
+ 'libsoup3'
+)
+makedepends=(
+ 'cargo'
+ 'meson'
+)
+checkdepends=(
+ 'appstream'
+# 'xorg-server-xvfb'
+)
source=("$pkgname-$pkgver.tar.gz::https://github.com/SeaDve/Mousai/archive/refs/tags/v$pkgver.tar.gz")
-sha256sums=('a777e9c6ad310f2bb85ac88fc6f0de96e712ed49bed6905bc7e8e54820af4e37')
+sha256sums=('f99f717bd9516dd6db92276a1a171ea97e2caa8f77e9d38fdf32218690a9cc27')
prepare() {
cd "Mousai-$pkgver"
@@ -32,7 +44,7 @@ build() {
check() {
# export CARGO_HOME="$srcdir/cargo-home"
# export RUSTUP_TOOLCHAIN=stable
-# meson test -C build --print-errorlogs || :
+# xvfb-run -a -s "-screen 0 1024x768x24" dbus-run-session meson test -C build --print-errorlogs || :
appstreamcli validate --no-net "build/data/${_app_id}.metainfo.xml" || :
desktop-file-validate "build/data/${_app_id}.desktop"