summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 39b3c236bc81..90606173d719 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
pkgname=mpfr-git
-pkgver=r13607.gec77070d4
+pkgver=4.2.0.r140.g4e0324cb2
pkgrel=1
pkgdesc="C library for multiple-precision floating-point computations with correct rounding"
arch=('i686' 'x86_64')
@@ -9,7 +9,7 @@ url="https://www.mpfr.org/"
license=('GPL3' 'LGPL3')
depends=('glibc' 'gmp')
makedepends=('git')
-provides=('mpfr')
+provides=("mpfr=$pkgver")
conflicts=('mpfr')
options=('staticlibs')
source=("git+https://gitlab.inria.fr/mpfr/mpfr.git")
@@ -19,9 +19,10 @@ sha256sums=('SKIP')
pkgver() {
cd "mpfr"
- _rev=$(git rev-list --count --all)
+ _tag=$(git tag -l --sort -v:refname | grep -E '^v?[0-9\.]+$' | head -n1)
+ _rev=$(git rev-list --count $_tag..HEAD)
_hash=$(git rev-parse --short HEAD)
- printf "r%s.g%s" "$_rev" "$_hash"
+ printf "%s.r%s.g%s" "$_tag" "$_rev" "$_hash" | sed 's/^v//'
}
build() {