summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 979b6075a3a7..ff18b7ca7926 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Philip Abernethy<chais.z3r0@gmail.com>
-pkgname=mpreal-hg
-pkgver=r112.248da9fd5d83
+pkgname=mpreal-git
+pkgver=3.6.7.r7.g2c5e632
pkgrel=1
pkgdesc="Multiple precision floating point (MPFR) arithmetic library for C++"
url="http://www.holoborodko.com/pavel/mpfr/"
@@ -8,14 +8,14 @@ arch=('any')
license=('GPL3')
depends=('mpfr')
-source=("${pkgname%-hg}::hg+https://bitbucket.org/advanpix/mpreal")
+source=("${pkgname%-git}::git+https://github.com/advanpix/mpreal.git")
sha512sums=('SKIP')
pkgver() {
- cd "${pkgname%-hg}"
- printf "r%s.%s" "$(hg identify -n)" "$(hg identify -i)"
+ cd "${pkgname%-git}"
+ git describe --long --tags | sed 's/^mpfrc++-//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
package() {
- install -Dm644 "${srcdir}"/${pkgname%-hg}/${pkgname%-hg}.h "${pkgdir}"/usr/include/${pkgname%-hg}.h
+ install -Dm644 "${srcdir}"/${pkgname%-git}/${pkgname%-git}.h "${pkgdir}"/usr/include/${pkgname%-git}.h
}