summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 7 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ed1e7a308dbc..4e4c1c9c1098 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Nicholas Fraser <nicholas.rd.fraser@gmail.com>
pkgname=msgpack-tools
-pkgver=0.5
+pkgver=0.6
pkgrel=1
pkgdesc="Command-line tools for converting between MessagePack and JSON"
arch=('i686' 'x86_64' 'mips64el' 'armv6h' 'armv7h' 'arm' 'aarch64')
@@ -9,7 +9,7 @@ license=('MIT')
depends=('gcc-libs')
makedepends=('cmake')
source=(https://github.com/ludocode/msgpack-tools/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz)
-sha256sums=('6f382a74fd8715a8a0e6a2561a9f10b16db7604b3139486908b4054709f81d08')
+sha256sums=('98c8b789dced626b5b48261b047e2124d256e5b5d4fbbabdafe533c0bd712834')
build() {
cd "$pkgname-$pkgver"
@@ -17,6 +17,11 @@ build() {
make
}
+check() {
+ cd "$pkgname-$pkgver"
+ make test
+}
+
package() {
cd "$pkgname-$pkgver"
make DESTDIR="$pkgdir/" install