summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 13 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 56393d6af0ed..fcb1497a1387 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,12 +3,12 @@
_pkgname='mycorrhiza'
pkgname="$_pkgname-git"
-pkgver=1.14.0.r7.gd0be765
+pkgver=1.14.0.r17.g7ad8a06
pkgrel=1
pkgdesc='Filesystem and git-based wiki engine written in Go using mycomarkup (built from latest commit)'
arch=('aarch64' 'armv7h' 'x86_64')
url="https://github.com/bouncepaw/$_pkgname"
-license=('AGPL3')
+license=('AGPL-3.0-or-later')
depends=('git' 'glibc')
makedepends=('git' 'go')
source=("git+$url.git")
@@ -38,6 +38,17 @@ pkgver() {
build() {
cd "$_pkgname"
+ # RFC-0023
+ # 🔗 https://rfc.archlinux.page/0023-pack-relative-relocs/
+ #
+ # ld(1) says: “Supported for i386 and x86-64.”
+ case "${CARCH:-unknown}" in
+ 'x86_64' | 'i386' )
+ export LDFLAGS="$LDFLAGS -Wl,-z,pack-relative-relocs"
+ ;;
+ * ) : pass ;;
+ esac
+
export CGO_CPPFLAGS="$CPPFLAGS"
export CGO_CFLAGS="$CFLAGS"
export CGO_CXXFLAGS="$CXXFLAGS"