summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 9 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fa0dac5ab355..4bbc4247b5b0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,18 @@
-# Maintainer: Soma Yamamoto <soya[underscore]daizu[at]proton[dot]me>
+# Maintainer: Soma Yamamoto <soya_daizu[at]proton[dot]me>
_name=myMPD
+_pkgname=mympd
pkgname=mympd-git
-pkgver=10.1.0.r5.geb5aea5e
+pkgver=10.2.1.r4.g18a28cfe
pkgrel=1
pkgdesc="A standalone and lightweight web-based MPD client"
arch=(x86_64)
url="https://github.com/jcorporation/myMPD"
license=(GPL3)
-depends=(lua openssl)
-makedepends=(git cmake flac jq libid3tag pcre2 perl)
+depends=(glibc lua)
+makedepends=(git cmake flac jq libid3tag openssl pcre2 perl)
conflicts=(mympd)
provides=(mympd)
-options=(debug)
source=(git+https://github.com/jcorporation/myMPD.git#branch=devel)
sha512sums=(SKIP)
@@ -24,15 +24,15 @@ pkgver() {
build() {
local cmake_options=(
-B build
- -S $_name
-DCMAKE_BUILD_TYPE=None
-DCMAKE_INSTALL_PREFIX=/usr
-DENABLE_FLAC=ON
+ -S $_name
-Wno-dev
)
cmake "${cmake_options[@]}"
- cmake --build build
+ cmake --build build --verbose
}
check() {
@@ -43,9 +43,10 @@ package() {
depends+=(
flac libFLAC.so
libid3tag libid3tag.so
+ openssl libssl.so
pcre2 libpcre2-8.so
)
DESTDIR="$pkgdir" cmake --install build
- install -vDm 644 $_name/{CHANGELOG,README}.md -t "$pkgdir/usr/share/doc/$pkgname/"
+ install -vDm 644 $_name/{CHANGELOG,README}.md -t "$pkgdir/usr/share/doc/$_pkgname/"
}