summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 12 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9b850d90937b..eb5528934ebd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,24 @@
-# Maintainer: Hexchain Tong <i at hexchain dot org>
-pkgname=neovim-remote
-pkgver=1.5.2
+pkgname=neovim-remote-git
+pkgver=1.5.2.r0.g9dd9c32
pkgrel=1
pkgdesc="Support --remote and friends for Neovim"
arch=(any)
url="https://github.com/mhinz/neovim-remote"
license=('GPL')
depends=('python-neovim')
-source=("git+https://github.com/mhinz/neovim-remote.git#tag=v${pkgver}")
+makedepends=('python-setuptools')
+source=("git+https://github.com/mhinz/neovim-remote.git")
sha1sums=('SKIP')
+conflicts=('neovim-remote')
+provides=('neovim-remote')
+
+pkgver() {
+ cd "$srcdir/${pkgname%%-git}"
+ git describe --tags --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
package() {
- cd "$srcdir/$pkgname"
+ cd "$srcdir/${pkgname%%-git}"
python setup.py install --root="$pkgdir/"
}