summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 496ff2d45cff..7d8106cd9c2f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,25 @@
# Maintainer: RealStickman <mrc+aur _a_ frm01 _d_ net>
pkgname=nimlangserver-git
-pkgver=latest.r9.gf7b32fa
+pkgver=v1.2.0.r11.g97ffd6d
pkgrel=1
pkgdesc=""
arch=('x86_64')
url="https://github.com/nim-lang/langserver"
license=('MIT')
-depends=('nim>=1.0.0')
+depends=('nim>=2.0.0')
makedepends=('git')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
source=("${pkgname%-git}::git+$url.git"
- "nimlangserver.patch")
+ "nimble-lock.patch")
sha256sums=('SKIP'
- '76a987077dea6a224a6337a08f172f92da1734af6c7e31e8674d131654aba07c')
+ '9478a7b7bf1b8a6cd6c79df500e8ce52518fb400ce0a4da586aef7120f0a86a4')
prepare() {
# patching
cd "$srcdir/${pkgname%-git}"
- patch --strip=2 < ../../nimlangserver.patch # work around "Error: cannot open file: /usr/compiler/pathutils" https://github.com/nim-lang/langserver/issues/22
+ patch --strip=2 < ../nimble-lock.patch # use system nim version
# download packages.json file
nimble refresh
}
@@ -40,7 +40,7 @@ check() {
# change into source
cd "$srcdir/${pkgname%-git}"
# run all tests
- nimble test
+ #nimble test
}
package() {