summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 10 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 06c44505dfd3..33ed86ab08f7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=nodejs-decktape
_npmname=decktape
-pkgver=3.4.0
+pkgver=3.10.0
pkgrel=1
pkgdesc='PDF exporter for HTML presentation frameworks'
arch=('any')
@@ -12,17 +12,17 @@ url='https://github.com/astefanutti/decktape'
license=('MIT')
depends=('npm' 'nodejs')
source=("${_npmname}-${pkgver}.tar.gz::https://github.com/astefanutti/"${_npmname}"/archive/v"${pkgver}".tar.gz")
-sha256sums=('655470713264220190d2fb9e52a8f20fc553d77102f73b13c32a2ed6f025078e')
+sha256sums=('fe629143e743e87fd0697cdeb7794f6bb09edd36255e0058a2a463555f21e7e8')
package() {
- local _npmdir="$pkgdir/usr/lib/node_modules/"
- mkdir -p $_npmdir
- cd $_npmdir
- npm install --user root -g --prefix "$pkgdir/usr" $_npmname@$pkgver
+ local _npmdir="$pkgdir/usr/lib/node_modules/"
+ mkdir -p $_npmdir
+ cd $_npmdir
+ npm install --user root -g --prefix "$pkgdir/usr" $_npmname@$pkgver
- find "$pkgdir/usr/bin" -type d -exec chmod 755 '{}' +
- find "$pkgdir/usr/lib/node_modules" -type d -exec chmod -R 755 '{}' +
+ find "$pkgdir/usr/bin" -type d -exec chmod 755 '{}' +
+ find "$pkgdir/usr/lib/node_modules" -type d -exec chmod -R 755 '{}' +
- install -Dm0644 "$pkgdir/usr/lib/node_modules/$_npmname/LICENSE" \
- "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm0644 "$pkgdir/usr/lib/node_modules/$_npmname/LICENSE" \
+ "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}