summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 21 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..65cda342543e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+pkgname=nodejs-graphite-cli
+_pkgname=${pkgname#nodejs-}
+pkgver=0.20.19
+pkgrel=1
+pkgdesc="graphite.dev terminal client"
+arch=('any')
+url="https://github.com/withgraphite/graphite-cli"
+license=('AGPL-3.0')
+depends=('nodejs')
+makedepends=('npm')
+options=(!strip)
+
+package() {
+ npm \
+ install \
+ --user root \
+ --global \
+ --prefix "${pkgdir}/usr" \
+ --cache "${srcdir}/npm-cache" \
+ "@withgraphite/${_pkgname}@${pkgver}"
+}