summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index eb0224793132..eecaeb4ecb14 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,11 @@
-# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
+# Maintainer: Mark Wagie <mark dot wagie at proton dot me>
pkgname=ntfix-git
pkgver=0.2.1.r6.g48f4bc1
pkgrel=1
pkgdesc="Fixes the problem of Proton games not running on NTFS partitions"
arch=('x86_64')
url="https://github.com/benjamimgois/ntfix"
-license=('GPL')
+license=('unknown')
depends=('gtk2')
makedepends=('git' 'lazarus')
provides=("${pkgname%-git}")
@@ -16,12 +16,12 @@ sha256sums=('SKIP'
'1ef509b7f32723e2ee41d33dbc0c8460b1e12f34ca52a7fc0fd7f74985a1a71b')
pkgver() {
- cd "$srcdir/${pkgname%-git}"
+ cd "${pkgname%-git}"
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd "$srcdir/${pkgname%-git}"
+ cd "${pkgname%-git}"
lazbuild \
--lazarusdir=/usr/lib/lazarus \
--build-all \
@@ -29,7 +29,7 @@ build() {
}
package() {
- cd "$srcdir/${pkgname%-git}"
+ cd "${pkgname%-git}"
install -Dm755 "${pkgname%-git}" -t "$pkgdir/usr/bin"
install -Dm644 "data/icons/${pkgname%-git}48.png" \
"$pkgdir/usr/share/icons/hicolor/48x48/apps/${pkgname%-git}.png"