summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD74
1 files changed, 19 insertions, 55 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3c07b8464729..690c48127498 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,67 +1,31 @@
-# Maintainer: Patrick Burroughs (Celti) <celti@celti.name>
-
-# Unofficial repository (x86_64 and i686) available:
-# Build scripts at: https://repo.celti.name/nuvolaplayer/
-#
-# # Both the packages and the database are signed:
-# # `pacman-key --recv-keys 123C3F8B058A707F86643316FA682BD8910CF4EA`
-# # `pacman-key --lsign-key 123C3F8B058A707F86643316FA682BD8910CF4EA`
-# [nuvolaplayer]
-# SigLevel = Required TrustedOnly
-# Server = https://repo.celti.name/archlinux/$repo/$arch
+# Maintainer: archlinux.info:tdy
pkgname=nuvolaplayer-git
-pkgver=3.1.0.r37.g4d5feb9
+pkgver=r1020.78b0333
pkgrel=1
-
-arch=('i686' 'x86_64')
-license=('GPL')
-pkgdesc='Cloud music integration for your Linux desktop.'
-url='https://tiliado.eu/nuvolaplayer/'
-
-source=("$pkgname::git+https://github.com/tiliado/nuvolaplayer"
- 'nuvola-app-git-1.0.1.template')
-sha256sums=('SKIP'
- '22fe31b839cd7f0e17047ebc3c2ff8ab53e032b42173fa81f83031815e30a33c')
-
-depends=('diorite-git' 'webkit2gtk' 'libarchive')
-makedepends=('git' 'python' 'vala')
-optdepends=('nuvola-app-amazon-cloud-player-git: Amazon Cloud Player integration'
- 'nuvola-app-bandcamp-git: Bandccamp integration'
- 'nuvola-app-deezer-git: Deezer integration'
- 'nuvola-app-google-play-music-git: Google Play Music integration'
- 'nuvola-app-groove-git: Microsoft Groove Music integration'
- 'nuvola-app-jango-git: Jango integration'
- 'nuvola-app-kexp-git: KEXP-FM (Seattle 90.3) integration'
- 'nuvola-app-logitech-media-server-git: Logitech Media Server integration'
- 'nuvola-app-mixcloud-git: Mixcloud integration'
- 'nuvola-app-owncloud-music-git: OwnCloud Music integration'
- 'nuvola-app-plex-git: Plex Media integration'
- 'nuvola-app-soundcloud-git: SoundCloud integration'
- 'nuvola-app-spotify-git: Spotify integration'
- 'nuvola-app-tunein-git: TuneIn integration'
- 'nuvola-app-yandex-music-git: Yandex.Music integration'
- 'nuvola-app-google-calendar-git: (Experimental) Google Calendar integration'
- 'nuvola-app-8tracks-git: 8tracks.com integration (not functional)'
- 'nuvola-app-hype-machine-git: Hype Machine integration (not functional)'
- 'nuvola-app-pandora-git: Pandora integration (not functional)' )
+pkgdesc="Cloud music integration for your Linux desktop"
+arch=(i686 x86_64)
+url=https://tiliado.eu/nuvolaplayer
+license=(GPL)
+depends=(diorite-git webkit2gtk libarchive)
+makedepends=(git python vala)
+provides=(${pkgname%-git})
+conflicts=(${pkgname%-git})
+source=($pkgname::git+https://github.com/tiliado/${pkgname/-/.})
+md5sums=(SKIP)
pkgver() {
- cd "$pkgname"
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ cd $pkgname
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {
- cd "$pkgname"
- python ./waf configure --prefix=/usr
- python ./waf build
+ cd $pkgname
+ python waf configure --prefix=/usr
+ python waf build
}
package() {
- cd "$pkgname"
- python ./waf install --no-system-hooks --destdir="${pkgdir}"
-
- # Installl makepkg template for nuvola-app-*-git integrations.
- install -Dm644 "${srcdir}/nuvola-app-git-1.0.1.template" "${pkgdir}/usr/share/makepkg-template/nuvola-app-git-1.0.1.template"
- ln -s nuvola-app-git-1.0.1.template "${pkgdir}/usr/share/makepkg-template/nuvola-app-git.template"
+ cd $pkgname
+ python waf install --no-system-hooks --destdir="$pkgdir"
}