summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 10 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index adc30aa54eef..4fb1bf1abde9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# Contributor: Laramy Black <laramy2020@gmail.com>
pkgname=nuvolaruntime
-pkgver=4.23.0
+pkgver=4.24.0
pkgrel=1
pkgdesc="Nuvola Apps Runtime - Tight integration of web apps with your desktop"
arch=(x86_64)
@@ -17,22 +17,23 @@ makedepends=(vala)
#optdepends=('nodejs-engine.io-client'
# 'nodejs-unit.js: for JavaScript unit tests')
#libappindicator-gtk3 is mandatory if enabled
-provides=(nuvolaplayer)
-conflicts=(nuvolaplayer)
+#provides=(nuvolaplayer)
+#conflicts=(nuvolaplayer)
+replaces=(nuvolaplayer)
source=("https://github.com/tiliado/$pkgname/archive/${pkgver}/${pkgname}-${pkgver}.tar.gz")
-sha256sums=('afc5115383410ab1207bd9e1d9ceab31c312100c11343239b1e4cac4588a6f31')
+sha256sums=('4928e2de5cec1403fd53c8b304488af65030a1e28d90ea1e1d383208c845be28')
build() {
cd "nuvolaplayer-${pkgver}"
./waf configure \
- --prefix=/usr \
- --libdir=/usr/lib \
+ --prefix=/usr \
+ --libdir=/usr/lib \
--dummy-engine \
--no-appindicator \
- --no-vala-lint \
- --no-js-lint \
+ --no-vala-lint \
+ --no-js-lint \
--no-strict \
- --no-unity
+ --no-unity
./waf build -v
}