summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d0e6936807ba
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: <tjmnkrajyej at gmail dot com>
+pkgname=odinls
+pkgver=880
+pkgrel=1
+pkgdesc='ols: language server for Odin'
+arch=(x86_64)
+url=https://github.com/DanielGavin/ols
+license=(MIT)
+depends=(odin)
+options=('!lto')
+source=(git+$url)
+sha256sums=(SKIP)
+
+pkgver() {
+ cd ols
+ git rev-list --count @
+}
+
+build() {
+ cd ols
+ ./build.sh
+}
+
+package() {
+ install -D ols/ols "$pkgdir/usr/bin/ols"
+}
+