summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 10 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 42d3f0003b88..f3d58b811119 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,24 @@
-# Maintainer: Caltlgin Stsodaat <contact@fossdaily.xyz>
+# Maintainer: Adrian Perez de Castro <aperez@igalia.com>
+# Contributor: Caltlgin Stsodaat <contact@fossdaily.xyz>
# Contributor: Javier Tia <javier.tia@gmail.com>
# otfinfo --info *.otf
_pkgname='Office-Code-Pro'
+_commit='d8fe9b1655a449d5fa4952d8388a626bfd87d652'
pkgname="${_pkgname,,}"
-pkgver=1.004
-pkgrel=3
+pkgver=1.004+1
+pkgrel=1
pkgdesc='Customized version of Source Code Pro font'
arch=('any')
-url='https://github.com/nathco/Office-Code-Pro'
+url="https://github.com/phooky/${_pkgname}"
license=('custom: SIL Open Font License 1.1')
-source=("${_pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz")
-sha256sums=('9bca923d17f6c47a586d8e4567d46ccfa58fb8b8e2247b5ee2a19da1597c58f6')
+source=("${_pkgname}::git+${url}#commit=${_commit}")
+makedepends=(git)
+sha256sums=(SKIP)
package() {
- cd "${_pkgname}-${pkgver}"
+ cd "${_pkgname}"
find 'Fonts' -type f -name "*.otf" -exec install -Dvm644 "{}" -t "${pkgdir}/usr/share/fonts/OTF" \;
install -Dvm644 'README.md' -t "${pkgdir}/usr/share/doc/${pkgname}"
install -Dvm644 'LICENSE.txt' "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"