summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 11 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a7672df4f733..a514cae274af 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgname=openafs-modules
_srcname=openafs
pkgver=1.6.21.1
-pkgrel=1
+pkgrel=2
pkgdesc="Kernel module for OpenAFS"
arch=('i686' 'x86_64' 'armv7h')
url="http://www.openafs.org"
@@ -16,10 +16,14 @@ makedepends=('linux-headers')
conflicts=('openafs-features-libafs' 'openafs<1.6.6-2')
options=(!emptydirs)
source=(http://openafs.org/dl/${pkgver}/${_srcname}-${pkgver}-src.tar.bz2
- 0001-Correct-m4-conditionals-in-curses.m4.patch)
+ 0001-Correct-m4-conditionals-in-curses.m4.patch
+ 0002-Linux-Test-for-__vfs_write-rather-than-__vfs_read.patch
+ 0003-Linux-Use-kernel_read-kernel_write-when-__vfs-varian.patch)
install=openafs-modules.install
sha256sums=('aed896b0f598e3033e9ceb2a1eae24addff9ec0bb2d713ab63945a449ded3a5a'
- '588cc4b220b7bd4783ffb44d9bfd490a67d1d4a58da20b952151fd842ca8f18d')
+ '250145d4abd704f739ade491e8d685873813a720b954f6c09a6186fb8662c415'
+ '28511f96c142eb918c4f92bf43427883f3f9eb32a8ea8a4de85b56c1b57957a4'
+ '4040a57c012498c06d60b678b072d6ce415f7b8b1a6fc01140b42c392515da36')
# Heuristic to determine version of installed kernel
# You can modify this if the heuristic fails
@@ -32,6 +36,10 @@ prepare() {
# Fix curses checks during configure (https://gerrit.openafs.org/12740/)
patch -p1 < ${srcdir}/0001-Correct-m4-conditionals-in-curses.m4.patch
+ # Fix compatibility with Linux 4.14
+ patch -p1 < ${srcdir}/0002-Linux-Test-for-__vfs_write-rather-than-__vfs_read.patch
+ patch -p1 < ${srcdir}/0003-Linux-Use-kernel_read-kernel_write-when-__vfs-varian.patch
+
# Only needed when changes to configure were made
./regen.sh -q
}