summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 14 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b3a93ddbc112..c0562c725557 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,10 +16,16 @@ makedepends=('libelf' 'linux-headers')
conflicts=('openafs-features-libafs' 'openafs<1.6.6-2')
options=(!emptydirs)
source=("http://openafs.org/dl/openafs/${pkgver}/${_srcname}-${pkgver}-src.tar.bz2"
- 0001-Temporary-fix-for-compilation-with-GCC-10.patch)
+ 0001-Temporary-fix-for-compilation-with-GCC-10.patch
+ 0002-LINUX-5.8-Replace-kernel_setsockopt-with-new-funcs.patch
+ 0003-LINUX-5.8-do-not-set-name-field-in-backing_dev_info.patch
+ 0004-LINUX-5.8-use-lru_cache_add.patch)
install=openafs-modules.install
sha256sums=('8b4e9d3180f1ecd752753da17ac630df04eb7007c90a921a5f6403c0339d2945'
- 'b067b59bf856d15ded1ee786d303eb7b7ff47edb5b3e078b1d43862b8db62368')
+ '3d0bf6960ef1eaab87492e93ea36c3b1a6b1e12877863abd7b64ad78e4637bce'
+ '5c02f2c152720bc790dfdf5f99b083b986acd34074da917efa9f39265eda7483'
+ '4373b0509c1eb7f4aec4cb11a231571f1015cdf3bef6e059c0df9e493e178e83'
+ '955f710fff9f535406800406bf128deccc209511b0aa9b6aacb6f3b4417a6a4d')
# Heuristic to determine version of installed kernel
# You can modify this if the heuristic fails
@@ -30,7 +36,12 @@ prepare() {
cd "${srcdir}/${_srcname}-${pkgver}"
# Fix compilation with GCC 10 (see https://bugs.gentoo.org/706738 and https://gerrit.openafs.org/14106)
- patch -p1 < "${srcdir}/0001-Temporary-fix-for-compilation-with-GCC-10.patch"
+ patch -p1 < "${srcdir}"/0001-Temporary-fix-for-compilation-with-GCC-10.patch
+
+ # Compatibility with Linux 5.8
+ patch -p1 < "${srcdir}"/0002-LINUX-5.8-Replace-kernel_setsockopt-with-new-funcs.patch
+ patch -p1 < "${srcdir}"/0003-LINUX-5.8-do-not-set-name-field-in-backing_dev_info.patch
+ patch -p1 < "${srcdir}"/0004-LINUX-5.8-use-lru_cache_add.patch
# Only needed when changes to configure were made
./regen.sh -q