summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 17 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0e9fb1daf09e..9f3b1b55cd40 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,8 +4,8 @@
# https://github.com/openvinotoolkit/openvino/issues/452#issuecomment-722941119
pkgname=openvino
-pkgver=2024.0.0
-pkgrel=1
+pkgver=2024.1.0
+pkgrel=3
pkgdesc='A toolkit for developing artificial inteligence and deep learning applications'
arch=('x86_64')
url='https://docs.openvinotoolkit.org/'
@@ -13,6 +13,7 @@ license=('Apache-2.0')
depends=('pugixml' 'onetbb')
optdepends=('intel-compute-runtime: for Intel GPU plugin'
'ocl-icd: for Intel GPU plugin'
+ 'level-zero-loader: for Intel NPU plugin'
'snappy: for tensorflow frontend'
'protobuf: for tensorflow, paddle and onnx frontends'
'python: for Python API'
@@ -47,11 +48,17 @@ source=("git+https://github.com/openvinotoolkit/openvino.git#tag=${pkgver}"
'git+https://github.com/google/snappy.git'
'git+https://github.com/ARM-software/ComputeLibrary.git'
'git+https://github.com/openvinotoolkit/mlas.git'
+ 'git+https://github.com/oneapi-src/level-zero.git'
+ 'git+https://github.com/intel/level-zero-npu-extensions.git'
+ 'git+https://github.com/openvinotoolkit/telemetry.git'
'openvino.conf'
'setupvars.sh'
'010-openvino-disable-werror.patch'
'020-openvino-use-protobuf-shared-libs.patch')
-sha256sums=('SKIP'
+sha256sums=('edf2a719de99981396784da9e42483a16c8a2e24453780693cc69d452b4b45b3'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
'SKIP'
'SKIP'
'SKIP'
@@ -75,8 +82,8 @@ sha256sums=('SKIP'
'SKIP'
'335a55533ab26bd1f63683921baf33b8e8e3f2732a94554916d202ee500f90af'
'e5024ad3382f285fe63dc58faca379f11a669bbe9f5d90682c59ad588aab434c'
- '1b420e3cc2afca11154c672123f001cf03cd2b96be3baafd229f6ee7d752419e'
- '17417f7193e94c7df32242c71d650d8beda2dadea8b05db131a7731a56e9c84a')
+ '0bbf46bef304dea08b318d1ffd564735b19e1afb6c0f41c98d216824cc630132'
+ '2329bb09c80ce44ae622da9d318d246b237e3a4d259d12f6b8920a249ec994bb')
export GIT_LFS_SKIP_SMUDGE='1'
@@ -106,6 +113,9 @@ prepare() {
git -C openvino config --local submodule.thirdparty/snappy.url "${srcdir}/snappy"
git -C openvino config --local submodule.ARMComputeLibrary.url "${srcdir}/ComputeLibrary"
git -C openvino config --local submodule.src/plugins/intel_cpu/thirdparty/mlas.url "${srcdir}/mlas"
+ git -C openvino config --local submodule.src/plugins/intel_npu/thirdparty/level-zero.url "${srcdir}/level-zero"
+ git -C openvino config --local submodule.src/plugins/intel_npu/thirdparty/level-zero-ext.url "${srcdir}/level-zero-npu-extensions"
+ git -C openvino config --local submodule.thirdparty/telemetry.url "${srcdir}/telemetry"
git -C openvino -c protocol.file.allow='always' submodule update
patch -d openvino -Np1 -i "${srcdir}/010-openvino-disable-werror.patch"
@@ -113,15 +123,14 @@ prepare() {
}
build() {
- export CFLAGS+=' -march=x86-64-v3'
- export CXXFLAGS+=' -march=x86-64-v3'
-
# note: does not accept 'None' build type
cmake -B build -S openvino \
-G 'Unix Makefiles' \
-DBUILD_TESTING:BOOL='OFF' \
-DCMAKE_BUILD_TYPE:STRING='Release' \
-DCMAKE_INSTALL_PREFIX:PATH='/opt/intel/openvino' \
+ -DENABLE_SSE42:BOOL='OFF' \
+ -DENABLE_AVX2:BOOL='OFF' \
-DENABLE_AVX512F:BOOL='OFF' \
-DENABLE_PYTHON:BOOL='ON' \
-DENABLE_CLANG_FORMAT:BOOL='OFF' \