summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 9 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b0c86748206b..25d57f51bf4c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: graysky <therealgraysky AT protonmail DOT com>
# Contributor: Kevin Schmidt <kevin.patrick.schmidt@googlemail.com>
pkgname=openwrt-devel
-pkgver=0.9
+pkgver=1.0
pkgrel=1
pkgdesc='Metapackage to pull all dependencies required to build OpenWrt'
arch=('x86_64')
@@ -10,7 +10,14 @@ license=('GPL')
depends=(
autoconf automake bash binutils bison bzip2 fakeroot file findutils flex gawk
gcc gettext git grep groff gzip libelf libtool libxslt m4 make ncurses
- openssl patch pkgconf python-setuptools rsync sed swig texinfo time unzip
+ openssl patch pkgconf 'python-setuptools>=1:69.0.3-6' rsync sed swig texinfo time unzip
util-linux wget which zlib
)
optdepends=(asciidoc help2man intltool perl-extutils-makemaker swig)
+
+package() {
+ # currently, OpenWrt expects /usr/bin/python3.11
+ # https://github.com/openwrt/openwrt/pull/15245
+ mkdir -p "$pkgdir"/usr/bin
+ ln -s python3.12 "$pkgdir"/usr/bin/python3.11
+}