summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD51
1 files changed, 25 insertions, 26 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f7122887522d..a94e383b22ef 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,54 +1,53 @@
# Maintainer: Vlad Frolov <frolvlad@gmail.com>
pkgname=owlink-git
-pkgver=0.0.0
+pkgver=r44.8e4e840
pkgrel=1
pkgdesc='An open Apple Wireless Direct Link (AWDL) implementation written in C'
-arch=('i686' 'x86_64' 'armv7h' 'armv6h' 'aarch64')
+arch=('i686' 'x86_64' 'armv7h' 'armv6h' 'aarch64' 'riscv64')
url=https://owlink.org/
-license=('GPL3')
-depends=('libpcap' 'libev' 'libnl')
-makedepends=('cmake' 'git')
-provides=('owlink' 'owl-git')
+license=('GPL-3.0-only')
+depends=('glibc' 'libpcap' 'libev' 'libnl')
+makedepends=('cmake' 'git' 'ninja')
+provides=('owlink' 'owl' 'owl-git')
conflicts=('owlink' 'owl' 'owl-git')
source=(
"$pkgname::git+https://github.com/seemoo-lab/owl.git#branch=master"
"git+https://github.com/google/googletest.git"
"git+https://github.com/radiotap/radiotap-library.git"
)
-sha512sums=(
- 'SKIP'
- 'SKIP'
- 'SKIP'
-)
+sha512sums=('SKIP'
+ 'SKIP'
+ 'SKIP')
pkgver() {
- cd "$pkgname"
- ( set -o pipefail
- git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
- printf "0.0.0.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
- )
+ cd "${srcdir}/${pkgname}"
+ ( set -o pipefail
+ git describe --long --tag --abbrev=7 2>/dev/null | sed 's/^v//g;s/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short=7 HEAD)"
+ )
}
prepare() {
- cd "$pkgname"
+# git -C "${srcdir}/${pkgname}" clean -dfx
+ cd "${srcdir}/${pkgname}"
+ git submodule init
git config submodule.googletest.url $srcdir/googletest
git config submodule.radiotap.url $srcdir/radiotap-library
- git submodule update --init
+ git -c protocol.file.allow=always submodule update
}
build() {
- cd "$pkgname"
- mkdir build -p && cd build
- cmake -DCMAKE_INSTALL_PREFIX=/usr ..
- make
+ cd "${srcdir}/${pkgname}"
+ cmake -DCMAKE_BUILD_TYPE=None \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -B build \
+ -G Ninja
+ ninja -C build
}
package() {
- cd "$pkgname/build"
- make DESTDIR="$pkgdir" install
-
- install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname" ../COPYING
+ DESTDIR="${pkgdir}" ninja -C "${srcdir}"/${pkgname}/build install
}
# vim:set ts=2 sw=2 et: