summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 13 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b7cc8387feea..d203913ddff8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,9 @@
# Contributor: ilikenwf
# Contributor: American_Jesus
pkgname=palemoon
-pkgver=28.8.4
-_commit=6e737debce5658a473b8b36197542bb2ff9fdd9f
+_repo=Pale-Moon
+pkgver=28.9.0
+_commit=651100f649cd0ae3a6b7ca85801b5e6f8d16599a
pkgrel=1
pkgdesc="Open source web browser based on Firefox focusing on efficiency."
arch=('i686' 'x86_64')
@@ -16,24 +17,29 @@ makedepends=('git' 'python2' 'autoconf2.13' 'unzip' 'zip' 'yasm' 'gconf'
'libpulse')
optdepends=('libpulse: PulseAudio audio driver'
'ffmpeg: various video and audio support')
-source=(git+"https://github.com/MoonchildProductions/UXP?signed#commit=${_commit}"
+source=(git+"https://github.com/MoonchildProductions/${_repo}?signed#commit=${_commit}"
+ git+"https://github.com/MoonchildProductions/UXP"
mozconfig.in)
sha1sums=('SKIP'
+ 'SKIP'
'802731e5af4d117961d3d6fc61bd1e23f69fd384')
validpgpkeys=('3059E09144F56804F0FBF4E126B40624BDBFD9F3')
prepare() {
sed 's#%SRCDIR%#'"${srcdir}"'#g' mozconfig.in > mozconfig
- sed -i 's#xlocale#locale#' UXP/intl/icu/source/i18n/digitlst.cpp
+ cd ${_repo}
+ git submodule init
+ git config submodule.platform.url "${srcdir}/UXP"
+ git submodule update
}
build() {
- cd UXP
+ cd ${_repo}
export MOZBUILD_STATE_PATH="${srcdir}/mozbuild"
export MOZCONFIG="${srcdir}/mozconfig"
export CPPFLAGS="${CPPFLAGS} -O2 -Wno-format-overflow"
- python2 mach build
+ ./mach build
}
package() {
@@ -55,5 +61,5 @@ package() {
"${pkgdir}/usr/share/icons/hicolor/128x128/apps/${pkgname}.png"
# install desktop file
- install -Dm644 "${srcdir}/UXP/application/palemoon/branding/official/palemoon.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+ install -Dm644 "${srcdir}/${_repo}/palemoon/branding/official/palemoon.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
}