summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 6 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f409ae874160..955d2fc10b43 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -85,13 +85,14 @@
# please use the official pam_ssh_agent_auth code base instead.
pkgname=pam_ssh_agent_auth-git
-pkgver=r22.f4b3932
-pkgrel=3
+pkgver=r29.099beb2
+pkgrel=1
pkgdesc="PAM module which permits authentication for arbitrary services via ssh-agent. (Git version including experimental ECC support)"
arch=('i686' 'x86_64' 'armv7h')
url="http://github.com/jbeverly/pam_ssh_agent_auth/"
license=('custom:OpenSSL')
-depends=('openssl-1.0')
+depends=('openssl')
+makedepends=('git')
optdepends=('openssh: standard ssh-agent'
'gnupg: gpg ssh-agent')
provides=('pam_ssh_agent_auth')
@@ -110,26 +111,14 @@ pkgver() {
}
prepare() {
- if ! [ -e openssl-1.0 ] ; then
- mkdir openssl-1.0
- fi
-
- if ! [ -e openssl-1.0/include ] ; then
- ln -s /usr/include/openssl-1.0 openssl-1.0/include
- fi
-
- if ! [ -e openssl-1.0/lib ] ; then
- ln -s /usr/lib/openssl-1.0 openssl-1.0/lib
- fi
-
cd "pam_ssh_agent_auth/"
git submodule init
git submodule update
}
-
+
build() {
cd "pam_ssh_agent_auth/"
- ./configure --prefix=/usr --with-mantype=man --libexecdir=/usr/lib/security --with-ssl-dir=../openssl-1.0
+ ./configure --prefix=/usr --with-mantype=man --libexecdir=/usr/lib/security --without-openssl-header-check
make
}