summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 19 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 853bc91ddca2..215a642fbaa7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,14 +5,16 @@ ENABLE_FLATPAK=0
ENABLE_SNAPD=0
pkgname=pamac-aur
-pkgver=10.0.0
+pkgver=10.0.1
pkgrel=1
_pkgfixver=$pkgver
-_commit='4431c12f2b7920ef437b9a30068f7a545d72549d'
-sha256sums=('142bb64f748e4edcedc71daa6997e403a4e7c4161b2aaf5dc522dee377cd7914')
+_commit='6138310b94dd26058521080930d313f4c788cbb4'
+sha256sums=('cf415ee1227d97c0ed64ea7f91a96d27217e01e4a2a6ba29f73fd1ab5f9fc3e0'
+ 'e9fe7c14d15cbce1d337749cf317e4460bce485b102b5c228b7efa479998d4fa'
+ 'c2b943318a01ba1f3dabbf32e48e6a6f4b4b774e167ab86c6bfee31aa4a3424c')
-pkgdesc="A Gtk3 frontend for libalpm"
+pkgdesc="A Gtk3 frontend, Package Manager based on libalpm with AUR and Appstream support"
arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h' 'aarch64')
url="https://gitlab.manjaro.org/applications/pamac"
license=('GPL3')
@@ -21,15 +23,16 @@ depends=('glib2>=2.42' 'json-glib' 'libsoup' 'dbus-glib' 'polkit' 'vte3>=0.38' '
'appstream-glib' 'archlinux-appstream-data')
optdepends=('polkit-gnome: needed for authentification in Cinnamon, Gnome'
- 'lxsession: needed for authentification in Xfce, LXDE etc.'
- 'pamac-tray-appindicator: tray icon for KDE')
-makedepends=('gettext' 'itstool' 'vala>=0.45' 'meson' 'ninja' 'gobject-introspection' 'xorgproto')
+ 'lxsession: needed for authentification in Xfce, LXDE etc.')
+makedepends=('gettext' 'itstool' 'vala>=0.46' 'gtk3>=3.22' 'asciidoc' 'meson' 'ninja' 'gobject-introspection' 'libappindicator-gtk3' 'xorgproto')
backup=('etc/pamac.conf')
-conflicts=('pamac')
-provides=("pamac=$pkgver-$pkgrel")
-options=(!emptydirs)
+conflicts=('pamac' 'pamac-tray-appindicator')
+provides=("pamac=$pkgver-$pkgrel" 'pamac-tray-appindicator')
+options=(!emptydirs !strip)
+
install=pamac.install
-source=("pamac-$pkgver-$pkgrel.tar.gz::$url/-/archive/$_commit/pamac-$_commit.tar.gz")
+source=("pamac-$pkgver-$pkgrel.tar.gz::$url/-/archive/$_commit/pamac-$_commit.tar.gz"
+ fix-appstream-data.sh fix-appstream-data.hook)
define_meson=''
if [ "${ENABLE_FLATPAK}" = 1 ]; then
depends+=('flatpak')
@@ -53,6 +56,7 @@ build() {
cd builddir
meson --buildtype=release \
--prefix=/usr \
+ -Denable-appindicator=true \
--sysconfdir=/etc $define_meson
# build
ninja
@@ -62,5 +66,9 @@ package() {
cd "$srcdir/pamac-$_commit/builddir"
DESTDIR="$pkgdir" ninja install
+ # cp -r "$srcdir/pamac-$_commit/data/gnome-shell/pamac-updates@manjaro.org" "$pkgdir/usr/share/gnome-shell/extensions"
+ # fix appstream issue
+ install -Dm644 "$srcdir/fix-appstream-data.hook" "$pkgdir/etc/pacman.d/hooks/fix-appstream-data.hook"
+ install -Dm755 "$srcdir/fix-appstream-data.sh" "$pkgdir/etc/pacman.d/hooks.bin/fix-appstream-data.sh"
}
# vim:set ts=2 sw=2 et: