summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 10 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 665e7d1c3189..1d4d5379c922 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=pari-git
_pkgname=pari
-pkgver=20190927.1fbf2d1af
+pkgver=20200425.46e7f37c5
pkgrel=1
pkgdesc='Computer algebra system designed for fast computations in number theory'
url='https://pari.math.u-bordeaux.fr/'
@@ -24,6 +24,12 @@ pkgver() {
build() {
cd "${srcdir}/${_pkgname}"
+
+ # Upstream Bill Allombert recommends linking gp statically against
+ # libpari.so with -flto to recover speed losses incurred when enabling
+ # pthread support. That's also what he now does for the Debian package.
+ export CFLAGS+=' -flto'
+
./Configure \
--prefix=/usr \
--with-readline \
@@ -42,4 +48,7 @@ package() {
cd "${srcdir}/${_pkgname}"
make DESTDIR="${pkgdir}" install
ln -sf gp.1.gz "${pkgdir}"/usr/share/man/man1/pari.1
+
+ cd Olinux-x86_64
+ make DESTDIR="${pkgdir}" install-bin-sta
}