summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 10 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f629f9935d28..cbf70c2e2807 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,32 @@
-# Maintainer: Samuel Walladge <samuel@swalladge.net>
+# Maintainer: <reg-archlinux AT klein DOT tuxli DOT ch>
+# Contributor: Samuel Walladge <samuel@swalladge.net>
pkgname=pc-git
_pkgname=pc
-pkgver=v0.1.0.r9.gbffb741
+pkgver=v0.1.1.r1.gc1e90f8
pkgrel=1
pkgdesc="Command line client for pastebins"
arch=('i686' 'x86_64')
url="https://git.sr.ht/~swalladge/pc"
-license=('APACHE' 'MIT')
+license=('GPL3')
provides=("pc")
conflicts=("pc")
makedepends=('cargo' 'git')
-source=("$pkgname::git+https://git.sr.ht/~swalladge/pc")
+source=("${pkgname}::git+https://git.sr.ht/~swalladge/pc")
sha256sums=('SKIP')
build() {
- cd "$pkgname"
+ cd "${pkgname}"
cargo build --release
}
pkgver() {
- cd "$pkgname"
+ cd "${pkgname}"
git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
package() {
- cd "$pkgname"
- install -Dm755 "target/release/$_pkgname" "$pkgdir/usr/bin/$_pkgname"
-
- install -Dm644 "README.md" "$pkgdir/usr/share/doc/${_pkgname}/README.md"
- install -Dm644 "LICENSE-APACHE" "$pkgdir/usr/share/licenses/${_pkgname}/LICENSE-APACHE"
- install -Dm644 "LICENSE-MIT" "$pkgdir/usr/share/licenses/${_pkgname}/LICENSE-MIT"
+ cd "${pkgname}"
+ install -Dm755 "target/release/${_pkgname}" "${pkgdir}/usr/bin/${_pkgname}"
+ install -Dm644 "README.md" "${pkgdir}/usr/share/doc/${_pkgname}/README.md"
}