summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 10 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1fda42d6d29e..a10163180860 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,24 @@
-# Maintainer: Kars Wang <jaklsy AT gmail.com>
+# Maintainer: Matthias Bethke <matthias@towiski.de>
pkgname='perl-archive-tar-wrapper'
-pkgver=0.38
+pkgver=0.39
+_distver=rel_039
pkgrel=1
pkgdesc="API wrapper around the 'tar' utility"
-_dist='Archive-Tar-Wrapper'
+_dist='archive-tar-wrapper-perl'
arch=('any')
-url="https://metacpan.org/release/$_dist"
+url="https://github.com/glasswalk3r/$_dist"
license=('PerlArtistic')
depends=('perl' 'perl-file-temp>=0' 'perl-file-which>=0' 'perl-log-log4perl>=0' 'perl-pathtools>=0' 'perl-ipc-run>=0')
checkdepends=()
makedepends=('perl-extutils-makemaker>=0')
provides=()
options=('!emptydirs' 'purge')
-source=("http://search.cpan.org/CPAN/authors/id/A/AR/ARFREITAS/$_dist-$pkgver.tar.gz")
-sha256sums=('19f3d0daa8b95cffb68c704350dd0674a23e1d2f14d032903b7e9609edb7b37a')
+source=("https://github.com/glasswalk3r/$_dist/archive/refs/tags/$_distver.tar.gz")
+sha256sums=('6f36a9117aac1a75a380c9e2247c183933c98f79a1e62c9a4c715c761e394441')
build() (
- cd "$srcdir/$_dist-$pkgver"
+ cd "$srcdir/$_dist-$_distver"
unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL=--skipdeps
/usr/bin/perl Makefile.PL
@@ -25,14 +26,14 @@ build() (
)
check() (
- cd "$srcdir/$_dist-$pkgver"
+ cd "$srcdir/$_dist-$_distver"
unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
export PERL_MM_USE_DEFAULT=1
make test
)
package() (
- cd "$srcdir/$_dist-$pkgver"
+ cd "$srcdir/$_dist-$_distver"
unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
make install INSTALLDIRS=vendor DESTDIR="$pkgdir"
)