summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 13 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b09070062239..843f272020ce 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,21 @@
-# Contributor: GPP <gergan@gmail.com>
-# Generator : CPANPLUS::Dist::Arch 1.30
+# Contributor: BluePeril <blueperil@blueperil.de>
+# Generator : CPANPLUS::Dist::Arch 1.32
pkgname='perl-catalyst-authentication-credential-http'
-pkgver='1.016'
+pkgver='1.018'
pkgrel='1'
-pkgdesc="HTTP Basic and Digest authentication"
+pkgdesc="HTTP Basic and Digest authentication for Catalyst"
arch=('any')
license=('PerlArtistic' 'GPL')
options=('!emptydirs')
-depends=('perl-catalyst-plugin-authentication>=0.10005' 'perl-catalyst-runtime>=0' 'perl-class-accessor>=0' 'perl-data-uuid>=0.11' 'perl-string-escape>=0' 'perl-uri>=0')
+depends=('perl-catalyst-plugin-authentication>=0' 'perl-catalyst-runtime>=0' 'perl-class-accessor>=0' 'perl-data-uuid>=0.11' 'perl-http-message>=0' 'perl-string-escape>=0' 'perl-uri>=0' 'perl>=5.006')
makedepends=()
-checkdepends=('perl-test-exception>=0' 'perl-test-mockobject>=0')
+checkdepends=('perl-test-exception>=0' 'perl-test-mockobject>=0' 'perl-test-needs>=0' 'perl-perlio-utf8-strict')
url='https://metacpan.org/release/Catalyst-Authentication-Credential-HTTP'
-source=('http://search.cpan.org/CPAN/authors/id/B/BO/BOBTFISH/Catalyst-Authentication-Credential-HTTP-1.016.tar.gz')
-md5sums=('65b5f09e7e3e46370b67b39922760b8e')
-sha512sums=('76285e217ecc9ec05f09451209a04843851d7c125e784408e55a0a671886f2bdec9ab36c528ded07d26c28ea389a58b6d24915530f08dd40687c83fd2a4c4509')
-_distdir="Catalyst-Authentication-Credential-HTTP-1.016"
+source=("http://search.cpan.org/CPAN/authors/id/E/ET/ETHER/Catalyst-Authentication-Credential-HTTP-${pkgver}.tar.gz")
+md5sums=('53ade94495ee45b5ff2871e5a241653d')
+sha512sums=('61dfcb2c42eea0b44bfda52681fd57d54a97cc830b9d1ce22838c4b8e8bf08f0a92c12fb2b434c89c194215af85d8be6e13083685597bec5f9b4dadeacca01d3')
+_distdir="Catalyst-Authentication-Credential-HTTP-${pkgver}"
build() {
( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
@@ -24,21 +24,21 @@ build() {
PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
MODULEBUILDRC=/dev/null
- cd "$srcdir/$_distdir"
+ cd "$_distdir"
/usr/bin/perl Makefile.PL
make
)
}
check() {
- cd "$srcdir/$_distdir"
+ cd "$_distdir"
( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
make test
)
}
package() {
- cd "$srcdir/$_distdir"
+ cd "$_distdir"
make install
find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
}