summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7686760c6d6d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Brian Bidulock <bidulock at openss7 dot org>
+
+pkgname=perl-file-blarf
+_cpanname=File-Blarf
+pkgver=0.12
+pkgrel=1
+pkgdesc="Perl/CPAN Module File::Blarf - Simple reading and writing of files"
+arch=(any)
+url="https://metacpan.org/release/$_cpanname"
+license=(PerlArtistic)
+options=('!emptydirs')
+source=("http://cpan.metacpan.org/authors/id/T/TE/TEX/$_cpanname-$pkgver.tar.gz")
+md5sums=('acf4abb13fdc033d888c61b5d101bad6')
+
+build() {
+ cd "$srcdir/$_cpanname-$pkgver"
+
+ # install module in vendor directories
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+package() {
+ cd "$srcdir/$_cpanname-$pkgver"
+ make install DESTDIR="$pkgdir/"
+
+ #remove perllocal.pod and .packlist
+ find "$pkgdir" -name perllocal.pod -delete
+ find "$pkgdir" -name .packlist -delete
+}