summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5bf7764dcbc2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+pkgname=perl-io-socket-multicast
+pkgver=1.12
+pkgrel=2
+pkgdesc="IO::Socket::Multicast - Object interface to socket communications for perl"
+arch=('any')
+license=('PerlArtistic' 'GPL')
+options=('!emptydirs')
+depends=('perl')
+makedepends=()
+url="http://search.cpan.org/dist/IO-Socket-Multicast/"
+source=("http://search.cpan.org/CPAN/authors/id/B/BR/BRAMBLE/IO-Socket-Multicast-$pkgver.tar.gz")
+md5sums=('c96e6cbb367b1d11ffe7bb9fbd833540')
+
+build() {
+ cd "$srcdir/IO-Socket-Multicast-$pkgver"
+ perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+package() {
+ cd "$srcdir/IO-Socket-Multicast-$pkgver"
+ make DESTDIR=$pkgdir install
+}