summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8bc1c39293e3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# This PKGBUILD was generated by cpan4pacman via CPANPLUS::Dist::Pacman
+# Contributor: gilles DOT quenot AT gmail DOT com
+
+pkgname=perl-lingua-translate-google
+_cpanname="Lingua-Translate-Google"
+pkgver=0.22
+pkgrel=2
+pkgdesc="Google backend for Lingua::Translate"
+arch=('any')
+url="http://search.cpan.org/~DYLAN/${_cpanname}"
+license=('GPL' 'PerlArtistic')
+depends=('perl-uri' 'perl-readonly' 'perl-libwww' 'perl-libwww>=1.73' 'perl-unicode-maputf8>=1.09')
+options=('!emptydirs')
+source=("http://search.cpan.org/CPAN/authors/id/D/DY/DYLAN/${_cpanname}-${pkgver}.tar.gz")
+md5sums=('d1f71ce4afe3298fa01f7b5a40c58139')
+
+build() {
+ cd $srcdir/${_cpanname}-${pkgver}
+ sed -i '/^auto_install/d' Makefile.PL
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
+ make || return 1
+}
+
+package() {
+ cd $srcdir/${_cpanname}-${pkgver}
+ find $pkgdir -name '.packlist' -delete
+ find $pkgdir -name '*.pod' -delete
+ make install DESTDIR=$pkgdir || return 1
+}