summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD64
1 files changed, 33 insertions, 31 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fac63411005b..b23c62924ce7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,40 @@
-# Contributor: : Kent Fredric <kentnl@cpan.org>
-# Maintainer: Kars Wang <jaklsy AT gmail.com>
+# Maintainer: Jimmy Xu <me at jimmyxu dot org>
+# Contributor: Kent Fredric <kentnl at cpan dot org>
+# Contributor: Kars Wang <jaklsy at gmail dot com>
-pkgname='perl-test-file-sharedir'
-pkgver=1.001001
+_perlmod='Test-File-ShareDir'
+_modnamespace=Test
+pkgname=perl-test-file-sharedir
+pkgver=1.001002
pkgrel=1
-pkgdesc='Create a Fake ShareDir for your modules for testing.'
-_dist='Test-File-ShareDir'
-arch=('any')
-url="https://metacpan.org/release/$_dist"
-license=('PerlArtistic')
-depends=('perl>=5.6' 'perl-file-sharedir>=1.00' 'perl-path-tiny>=0.018' 'perl-class-tiny>=0' 'perl-file-copy-recursive>=0' 'perl-exporter>=5.57' 'perl-scope-guard>=0' 'perl-parent>=0' 'perl-carp>=0')
-checkdepends=('perl>=5.6' 'perl-pathtools>=0' 'perl-extutils-makemaker>=0' 'perl-test-simple>=0.96' 'perl-test-fatal>=0' 'perl-lib>=0')
-provides=('perl-test-file-sharedir-dist=1.001001' 'perl-test-file-sharedir-module=1.001001' 'perl-test-file-sharedir-object-dist=1.001001' 'perl-test-file-sharedir-object-inc=1.001001' 'perl-test-file-sharedir-object-module=1.001001' 'perl-test-file-sharedir-tempdirobject=1.001001' 'perl-test-file-sharedir-utils=1.001001')
-options=('!emptydirs' 'purge')
-source=("http://search.cpan.org/CPAN/authors/id/K/KE/KENTNL/$_dist-$pkgver.tar.gz")
-sha256sums=('c8815ee3644949ad6419616c2706a04b3c22d709bfb610ad5c4cfe78884a8658')
+pkgdesc="Create a Fake ShareDir for your modules for testing."
+arch=("any")
+url="http://search.cpan.org/dist/$_perlmod"
+license=('GPL' 'PerlArtistic')
+depends=('perl' 'perl-class-tiny' 'perl-file-copy-recursive' 'perl-file-sharedir' 'perl-path-tiny' 'perl-scope-guard' 'perl-test-fatal')
+options=('!emptydirs')
+source=("http://cpan.perl.org/modules/by-module/$_modnamespace/$_perlmod-$pkgver.tar.gz")
+sha256sums=('b33647cbb4b2f2fcfbde4f8bb4383d0ac95c2f89c4c5770eb691f1643a337aad')
-build() (
- cd "$srcdir/$_dist-$pkgver"
- unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
- export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL=--skipdeps
- /usr/bin/perl Makefile.PL
+build() {
+ cd "$srcdir/$_perlmod-$pkgver"
+
+ # Install module in vendor directories.
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
make
-)
+}
+
+check() {
+ cd "$srcdir/$_perlmod-$pkgver"
-check() (
- cd "$srcdir/$_dist-$pkgver"
- unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
- export PERL_MM_USE_DEFAULT=1
+ # Install module in vendor directories.
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
make test
-)
+}
+
+package() {
+ cd "$srcdir/$_perlmod-$pkgver"
+ make install DESTDIR="$pkgdir/"
+}
-package() (
- cd "$srcdir/$_dist-$pkgver"
- unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
- make install INSTALLDIRS=vendor DESTDIR="$pkgdir"
-)
+# vim:set ts=2 sw=2 et: