summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 3 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c038a0852c6b..0d823714c51b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Marco44 (Marc Cousin) <cousinmarc at gmail dot com>
pkgname=pg_qualstats-git
_gitname=pg_qualstats
-pkgver=dd6fbf4
+pkgver=2.0.4.1.r6.g66b3037
pkgrel=1
pkgdesc="Capture qualifiers the same way as pg_stat_statement does for statements"
arch=('i686' 'x86_64' 'armv7h' 'aarch64')
@@ -11,15 +11,13 @@ depends=('postgresql')
builddepends=()
makedepends=(git)
options=(!emptydirs !libtool)
-source=('git://github.com/powa-team/pg_qualstats.git')
+source=('git+https://github.com/powa-team/pg_qualstats.git')
md5sums=('SKIP')
install='pg_qualstats-git.install'
pkgver() {
cd $_gitname
- tag=`git tag | grep REL | tail -1`
- commit=`git log --format="%h" -n 1`
- echo "$tag_$commit"
+ git describe --long --tags | sed 's/.*\///;s/REL//;s/_/./g;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {