summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--[-rwxr-xr-x]PKGBUILD121
1 files changed, 53 insertions, 68 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2ef658af4da3..edbb5591d10b 100755..100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,82 +1,67 @@
# Maintainer: Saiki81 <saikia81 at hotmail dot com>
+# Contributor: Christopher Arndt <aur -at- chrisarndt -dot- de>
# adapted from package: pianoteq-stage-trial-bin
-# adapted from pkgbuild creator: CrocoDuck <crocoduck dot oducks at gmail dot com>
-
+# adapted from pkgbuild creator: CrocoDuck <crocoduck dot oducks at gmail dot com>
pkgname=pianoteq-stage5
pkgver=5.8.1
-pkgrel=1
+pkgrel=2
pkgdesc="Virtual piano instrument using physical modelling synthesis. Both standalone and plugin versions."
arch=('i686' 'x86_64')
url="https://www.pianoteq.com/pianoteq5"
-license=('LGPL')
+license=('custom')
depends=('alsa-lib' 'freetype2' 'libxext')
-makedepends=('gendesk' 'wget' 'p7zip')
-optdepends=()
-provides=("${pkgname%-*}")
-conflicts=("${pkgname%-*}" "pianoteq-stage-bin", "pianoteq-standard-trial-bin")
-source=('https://www.pianoteq.com/images/logo/pianoteq_icon_128.png')
-sha256sums=('94ee64cf6688a49d74f0bf70d811e7466abac103feeab17496a89f828afcc6d3')
+makedepends=('gendesk')
+optdepends=('jack: JACK audio and MIDI support')
+provides=("pianoteq5")
+conflicts=("pianoteq5")
+source=("local://pianoteq_stage_linux_v${pkgver//./}.7z"
+ 'https://www.pianoteq.com/images/logo/pianoteq_icon_128.png')
+sha256sums=('ae0100a22432e73c2a7df8890b89239f04d3adc5a6d97440af9517e8e75187af'
+ '94ee64cf6688a49d74f0bf70d811e7466abac103feeab17496a89f828afcc6d3')
+
+_pianoteq_type="Pianoteq 5 STAGE"
+# Define architecture specific file directory:
+if [[ "$CARCH" == i686 ]]; then
+ archdir=i386
+else
+ archdir=amd64
+fi
-# Define the target archive filename:
-_pianoteqfilename=pianoteq_stage_linux_v${pkgver//./}.7z
-# Define its checksum:
-_pianoteqsha256sum=ae0100a22432e73c2a7df8890b89239f04d3adc5a6d97440af9517e8e75187af
+build() {
+ cd "$srcdir/$_pianoteq_type/"
-prepare(){
- # the source package must be downloaded manually
- # this can be done by going to the link here:
- # https://www.pianoteq.com/download?file=pianoteq_stage_linux_v581.7z
- # the checksum will still be validated
- if [ ! -f "../$_pianoteqfilename" ]
- then
- echo "File not found!"
- echo "Pianoteq installation binary file is not found!"
- echo -e "For this package a manual download of the Pianoteq installation binary is needed."
- echo -e "Please go to 'https://www.pianoteq.com/download?file=${_pianoteqfilename}'"
- echo -e "and log in with your user account."
- echo -e "The archive should be in the same directory as the PKGBUILD!"
- exit;
- exit;
- fi
- # move the dependency to ./src/
- mv ../$_pianoteqfilename ./
- # Check integrity:
- echo "$_pianoteqsha256sum $_pianoteqfilename" | sha256sum -c || { echo 'Checksum failed!'; exit 1; }
- # Extract:
- 7z x $_pianoteqfilename
- # Generate Desktop Entry:
- gendesk -f -n --pkgname "$pkgname" --pkgdesc "$pkgdesc" --name='pianoteq 5' --exec='pianoteq\ 5' --categories 'Audio;Sequencer;Midi;AudioVideoEditing;Music;AudioVideo;'
- echo "Note: Try running pianoteq from a shell, if problems occur!"
+ # Generate Desktop Entry:
+ gendesk -f -n \
+ --pkgname "$pkgname" \
+ --pkgdesc "$pkgdesc" \
+ --name="${_pianoteq_type}" \
+ --exec='pianoteq5' \
+ --categories 'Audio;Sequencer;Midi;AudioVideoEditing;Music;AudioVideo;'
}
-package(){
- _pianoteq_type="Pianoteq 5 STAGE"
- # Define architecture specific file directory:
- if [[ "$CARCH" == i686 ]]; then
- archdir=i386
- else
- archdir=amd64
- fi
- # Install program files:
- install -Dm 755 "$srcdir/$_pianoteq_type/$archdir/$_pianoteq_type" "$pkgdir/usr/bin/pianoteq 5"
- install -Dm 755 "$srcdir/$_pianoteq_type/$archdir/$_pianoteq_type.so" "$pkgdir/usr/lib/vst/pianoteq 5.so"
- cd "$srcdir/$_pianoteq_type/$archdir/$_pianoteq_type.lv2"
- for i in *; do
- install -D "$i" "$pkgdir/usr/lib/lv2/Pianoteq 5.lv2/$i"
- done
- cd $srcdir
- # Install desktop launcher:
- install -Dm 644 "$srcdir/pianoteq_icon_128.png" "$pkgdir/usr/share/pixmaps/$pkgname.png"
- install -Dm 644 "$srcdir/$pkgname.desktop" "$pkgdir/usr/share/applications/${pkgname%-*}.desktop"
- # Install the license:
- install -d "$pkgdir/usr/share/licenses/$pkgname"
- ls -a
- install -m 644 "$_pianoteq_type"/*Licence* "$pkgdir/usr/share/licenses/$pkgname/"
- # Install the Documentation:
- install -D "$_pianoteq_type/README_LINUX.txt" "$pkgdir/usr/share/doc/${pkgname%-*}/README_LINUX.txt"
- cd "$srcdir/$_pianoteq_type/Documentation"
- for i in *; do
- install -D "$i" "$pkgdir/usr/share/doc/${pkgname%-*}/$i"
- done
+package() {
+ cd "$srcdir/$_pianoteq_type/"
+
+ # Install binaries:
+ install -Dm 755 "$archdir/${_pianoteq_type}" "$pkgdir/usr/bin/pianoteq5"
+ install -Dm 755 "$archdir/${_pianoteq_type}.so" "$pkgdir/usr/lib/vst/pianoteq5.so"
+
+ for i in "$archdir/${_pianoteq_type}.lv2/"*; do
+ install -D "$i" "$pkgdir/usr/lib/lv2/Pianoteq 5.lv2/${i##*/}"
+ done
+
+ # Install desktop launcher:
+ install -Dm 644 "$srcdir/pianoteq_icon_128.png" "$pkgdir/usr/share/pixmaps/$pkgname.png"
+ install -Dm 644 "$pkgname.desktop" "$pkgdir/usr/share/applications/pianoteq5.desktop"
+
+ # Install the license:
+ install -d "$pkgdir/usr/share/licenses/${pkgname}"
+ install -m 644 *Licence* "$pkgdir/usr/share/licenses/${pkgname}/"
+
+ # Install the documentation:
+ install -D README_LINUX.txt "$pkgdir/usr/share/doc/${pkgname}/README_LINUX.txt"
+ for i in "Documentation/"*; do
+ install -D "$i" "$pkgdir/usr/share/doc/${pkgname}/${i##*/}"
+ done
}