summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cd5bc25e7cd6..186f58fcf97e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=pkgtop-git
pkgdesc="Interactive package manager & resource monitor"
-pkgver=1.0.0
+pkgver=r315.19d57fb
pkgrel=1
arch=('any')
url="https://github.com/keylo99/pkgtop"
@@ -14,6 +14,11 @@ conflicts=("${pkgname%-git}")
source=('git://github.com/keylo99/pkgtop.git#branch=master')
sha256sums=('SKIP')
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
build() {
cd "$srcdir/${pkgname%-git}/src"
go get -d ./...