summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a16acc909464..77dc8db1d40f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_upstream_name=plasma-applet-ambientnoise
pkgname=plasma5-applets-ambientnoise
pkgver=0.5.0
-pkgrel=1
+pkgrel=2
pkgdesc="Plasmoid for ambient noise reproduction"
arch=('any')
url="https://github.com/m-pilia/plasma-applet-ambientnoise"
@@ -14,8 +14,11 @@ optdepends=('anoise-media: noise files and icons'
'anoise-community-extension3: noise files and icons'
'anoise-community-extension4: noise files and icons'
'anoise-community-extension5: noise files and icons')
-makedepends=('extra-cmake-modules'
- 'git')
+makedepends=(
+ 'extra-cmake-modules'
+ 'git'
+ 'kdelibs4support'
+)
source=("https://github.com/m-pilia/${_upstream_name}/archive/${pkgver}.tar.gz")
sha256sums=('d0936c0273b2877545edecb06316eed99ae4225b0bf1a889262e42ac5abaa314')
@@ -24,7 +27,7 @@ prepare() {
mkdir "${_build_dir}" || :
cd "${_build_dir}"
- cmake .. -DCMAKE_INSTALL_PREFIX="`kf5-config --prefix`" \
+ cmake .. -DCMAKE_INSTALL_PREFIX="$(kf5-config --prefix)" \
-DCMAKE_BUILD_TYPE=Release
}