summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 11 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4ac40cbdf318..65d5858e04b4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,23 +3,25 @@
pkgname=plasmoidviewer-debug
_pkgname=plasma-sdk
-pkgver=5.15.0
+pkgver=5.27.8
+_dirver=$(echo $pkgver | cut -d. -f1-3)
pkgrel=1
pkgdesc='Debug build of plasmoidviewer allowing to debug QML code'
arch=(x86_64)
url='https://www.kde.org/workspaces/plasmadesktop/'
license=(LGPL)
-depends=(plasma-framework)
-makedepends=(extra-cmake-modules kitemmodels python2 kdoctools ktexteditor)
+depends=(plasma-framework5)
+makedepends=(extra-cmake-modules perl kdoctools5 ktexteditor5)
options=(!strip)
groups=(plasma)
-source=("https://download.kde.org/stable/plasma/$pkgver/${_pkgname}-$pkgver.tar.xz" # {,.sig}
- '0001-Enable-QML-debugging.patch')
-sha256sums=('a8a514775ded362b4b15190eb451bc0ef7b2564630f6937daf871a92311eb812'
- '1c612d2cb08e9435e265120a2f94b13a62833344abea7eb2dd7c03a93ba6ed56')
-validpgpkeys=('2D1D5B0588357787DE9EE225EC94D18F7F05997E' # Jonathan Riddell
+source=(https://download.kde.org/stable/plasma/$_dirver/$_pkgname-$pkgver.tar.xz{,.sig}
+ 0001-Enable-QML-debugging.patch)
+sha256sums=('9f961d5ce3a5fe7e945eb397d103435954669baba521f04a81a40345f47490bb'
+ 'SKIP'
+ 'SKIP')
+validpgpkeys=('E0A3EB202F8E57528E13E72FD7574483BB57B18D' # Jonathan Esk-Riddell <jr@jriddell.org>
'0AAC775BB6437A8D9AF7A3ACFE0784117FBCE11D' # Bhushan Shah <bshah@kde.org>
- 'D07BD8662C56CB291B316EB2F5675605C74E02CF' # David Edmundson
+ 'D07BD8662C56CB291B316EB2F5675605C74E02CF' # David Edmundson <davidedmundson@kde.org>
'1FA881591C26B276D7A5518EEAAF29B42A678C20') # Marco Martin <notmart@gmail.com>
prepare() {