summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 19 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d44f1cc3f7f8..da16ccd6caad 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,24 @@
-# Maintainer: Will Price <will.price94+aur@gmail.com>
+# Maintainer: S garnica < swhaat at github >
+# Contributor: Will Price <will.price94+aur@gmail.com>
# Contributor: Brice Waegeneire <bricewge at gmail dot com>
pkgname=platformio-git
_pkgname=platformio-core
-pkgver=v3.3.0.r296.gaa1c7609
+pkgver=v3.6.4.r31.g31d4706a
pkgrel=1
pkgdesc="A cross-platform code builder and library manager"
arch=('any')
url="http://platformio.org/"
license=('GPL')
-depends=('python2'
- 'python2-arrow'
- 'python2-bottle'
- 'python2-click-5.1'
- 'python2-colorama'
- 'python2-lockfile'
- 'python2-pyserial'
- 'python2-requests'
- 'python2-semantic-version')
+depends=('python-setuptools'
+ 'python-arrow'
+ 'python-bottle'
+ 'python-click-5.1'
+ 'python-colorama'
+ 'python-lockfile'
+ 'python-pyserial'
+ 'python-requests'
+ 'python-semantic-version')
optdepends=('energia: For MSP430 based projects'
'arduino: For Arduino based projects')
source=('git+https://github.com/platformio/platformio-core.git')
@@ -28,7 +29,13 @@ pkgver() {
git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
+build()
+{
+ cd "${srcdir}/${_pkgname}"
+ python setup.py build
+}
+
package() {
cd "$srcdir/${_pkgname}"
- python2 setup.py install --root="$pkgdir/" --optimize=1
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
}