summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 8 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ae5d245b2f95..57e5792950ac 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,39 +1,33 @@
# Maintainer: Igor Dyatlov <dyatlov.igor@protonmail.com>
pkgname=playhouse
-_pkgname=Playhouse
pkgver=1.0
_commit=287811d971872b51bb6127a35610d1442e15b1f4
-pkgrel=1
+pkgrel=2
pkgdesc="A Playground for HTML/CSS/JavaScript"
arch=('x86_64' 'aarch64')
url="https://github.com/sonnyp/Playhouse"
license=('GPL3')
depends=('libadwaita' 'webkit2gtk-5.0' 'gjs')
-makedepends=('git' 'blueprint-compiler' 'meson')
+makedepends=('git' 'blueprint-compiler' 'python-gobject' 'meson')
checkdepends=('appstream-glib')
-source=("git+https://github.com/sonnyp/Playhouse.git#commit=${_commit}"
- 'git+https://github.com/sonnyp/troll.git')
+source=("${pkgname}-${pkgver}::git+$url#commit=$_commit"
+ 'git+https://github.com/sonnyp/troll.git')
b2sums=('SKIP'
'SKIP')
-pkgver() {
- cd "$srcdir/$_pkgname"
- git describe --tags | sed 's/^v//;s/-/+/g'
-}
-
prepare() {
- cd "$srcdir/$_pkgname"
+ cd "$pkgname-$pkgver"
git submodule init
git config submodule.src/troll.url "$srcdir/troll"
- git submodule update
+ git -c protocol.file.allow=always submodule update --init --recursive
# This is not a Flatpak
- sed -i 's|app/bin|usr/bin|g' "$srcdir/$_pkgname"/src/meson.build
+ sed -i 's|app/bin|usr/bin|g' src/meson.build
}
build() {
- arch-meson "${_pkgname%-git}" build
+ arch-meson "$pkgname-$pkgver" build
meson compile -C build
}