summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 5 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1435810744ea..da915ff8e044 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Victor Tran <vicr12345 at gmail dot com>
pkgname=plymouth-theme-bgrt-cactus
-pkgver=20200711
+pkgver=20210802
pkgrel=1
pkgdesc="Plymouth theme with Cactus branding"
arch=("x86_64")
@@ -8,14 +8,16 @@ depends=('plymouth' 'ttf-contemporary')
makedepends=('git')
url="https://vicr123.com/cactus"
license=('GPL3')
-source=('git+https://github.com/vicr123/bgrt-cactus.git')
+source=("$pkgname-repo"::'git+https://github.com/vicr123/bgrt-cactus.git')
sha256sums=('SKIP')
pkgver() {
+ cd "$pkgname-repo"
git log -1 --format="%at" | xargs -I{} date -d @{} +%Y%m%d
}
package() {
+ cd "$pkgname-repo"
mkdir -p $pkgdir/usr/share/plymouth/themes/bgrt-cactus/
- cp bgrt-cactus/* $pkgdir/usr/share/plymouth/themes/bgrt-cactus/
+ cp * $pkgdir/usr/share/plymouth/themes/bgrt-cactus/
}